May 16, 2012

Diablo 3 Nvidia 310m Optimus issue

Posted May 16, 2012


While the server is down, I'm gonna blog about an issue I found in my Optimus-enabled laptop. For those who don't know, Optimus is a technology by Nvidia that allows the laptop to shift between the discreet video card and the built in intel video card in real-time depending on the need of the system in order to save on precious battery life.

The issue is Diablo III doesn't use the Nvidia card and continues to use the Intel card resulting in poor performance. I've verified this using GPU-Z. I was surprised that even the login screen is choppy / laggy.

The workaround: Right click the Diablo 3 icon / executable > Run with graphics processor > Select Nvidia card. This significantly increased the performance of the game.

If you don't see the option "Run with graphics processor" option in your context menu, go to Nvidia Control Panel, click "View" menu then select "Add Run with graphics processor to context menu" option.

My Specs:
Asus UL80JT
Nvidia 310M Optimus / Intel GMA HD
4gb memory

[update] For those experiencing crash, lockups, freeze, hangs in UL80JT. Try to update your BIOS to version 215.

21 comments:

  1. hi may i ask what version is your driver for your nvidia 310m?

    ReplyDelete
    Replies
    1. I just installed the verde beta 301.24 from nvidia.com, previously I was using 257.21

      Delete
    2. thanks for the reply manny ill try the verde beta 301.24 i hope it works well with D3 and StarCraft 2.

      By the way do also play starcraft2?

      Delete
    3. Note that I have to update my laptop's BIOS for the latest driver to work. Previously, I experience lockups. I only played beta of SC2. You're welcome; anytime

      Delete
  2. Your game doesn't crash at all? Mine crashes at the loading screen. Also thanks for the tip!

    ReplyDelete
    Replies
    1. No, I'm level 10 now and I experienced no crash / freeze / hang / lockup / bsod :)) My 310m is even overclocked! What laptop model are you using? Also, possibly related to your video card driver. Try to update

      Delete
    2. i have the ul80jt model. i upgraded to the beta drivers as well. still crashes at either the login or loading screen for me

      Delete
    3. Update your BIOS to 215.

      Go to support.asus.com, search UL80JT, go to downloads, select your operating system. Go to BIOS, download 215. Go to BIOS Utilities, download the utility. Extract the downloaded files, install the winflash utility, open it then select the downloaded 215 bios. :) Hope it helps!

      Delete
  3. are you running this on the highest settings?

    ReplyDelete
    Replies
    1. Texture - High, Shadow - Medium, Physics - Low, Clutter - Medium, Anti-aliasing - Off, Low FX - Off. Note my 310m is overclocked.

      Delete
    2. I actually think you can run phyics, clutter on high and AA on.
      My card's not overclocked and I'll still get 25-30fps with those settings.
      Although, my screen res is 1366x768 (native)

      Delete
    3. It will be slow on some parts of the map, esp Act II

      Delete
  4. Manny may i know what is your suggested settings in Starcraft2???

    ReplyDelete
    Replies
    1. I haven't played SC2 in ages! :)

      Delete
  5. Many I have checked asus support and they don´t have any driver update for the 310M since 2010. Did you installed standard Nvidia Drivers for the card? Does any 310M nvidia driver works well with optimus system? I have the feeling that if I install a standard NVIDIA driver for my 310M with optimus, the card/system will crash while trying to play... please help :)

    ReplyDelete
    Replies
    1. I installed Nvidia Verde driver from nvidia.com. If you're crashing, update your BIOS first. Are you using the latest BIOS version (215)?

      Delete
  6. Probably not, as I have never upgraded it (U43JC). I haven´t bought D3 yet, I was checking if it is compatible. I will give it a try and if it doesn´t work with my current drivers I will update BIOS + graphic drivers :)
    Thanks a lot for your quick reply!

    PS. I play SC2 with the 310M, i5 and 4GB RAM, medium-high settings and I have no issues

    ReplyDelete
  7. how did you overclock your 310m manny???

    ReplyDelete
    Replies
    1. I will post a blog about it very soon. Thanks!

      Delete
  8. @Han Solo- do you still play SC2 upuntil now??? cause i also have 310m and when i did some updates on it and latest patch from SC2 my recommended settings did happen to become low to all settings but before that it was medium-high aswell...

    ReplyDelete
    Replies
    1. No, I am afraid I stopped playing around 6 months ago, it was too addictive!

      Diablo 3 runs smoothly on low settings with old drivers (26X I think)

      Delete